Index Changes

Planning for GlassFish ESB Installation

Contents

Preparing for Installation

  • Select the system(s) that will host NetBeans.
  • Ensure that each system that you select meets the system requirements for GlassFish ESB. For more information on resource requirements, see Before You Install.

JDK and JAVA_HOME

The Java Development Kit (JDK) must be installed, and the JAVA_HOME environment variable must be set, on the computer on which you install GlassFish ESB prior to beginning the installation. Different operating systems require different JDK.

The following list provides the GlassFish ESB JDK requirements by platform.

Solaris
JDK5: At least release 1.5.0_14
JDK6: At least release 1.6.0_03
Linux (Red Hat and SUSE)
JDK5: At least release 1.5.0_14
JDK6: At least release 1.6.0_03
AIX 5.3
JDK5: At least release 1.5.0_14
Macintosh
JDK5: The latest 1.5 release supported by Apple
Microsoft Windows
JDK5: At least release 1.5.0_14
JDK6: At least release 1.6.0_03
Caution - It is not recommended to use JDK 1.6.0_13 or 1.6.0_14 with GlassFish ESB v2.1 due to issues with several of the wizards used to develop applications. In addition, the GlassFish ESB Installer fails on Windows when using JDK 1.6.0_13 or 1.6.0_14. The GlassFish ESB Installer does not support JDK release 1.6.0_04 in the 64–bit version on the Solaris SPARC or AMD 64–bit environments. The installer also does not support JDK 1.6.0 or later on AIX 5.3.

Previous Next


Return to GlassFish ESB Documentation Home

JSPWiki v2.4.100
[RSS]
« Home Index Changes Prefs
This page (revision-13) was last changed on 17-Jun-09 14:28 PM, -0700 by CarolT